<!DOCTYPE html>
<html lang="en">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="http://gmpg.org/xfn/11">
<link rel="pingback" href="https://haathitime.com/xmlrpc.php">

<title>Day 288: All along this love was right in front of me</title>
<script type="text/javascript">
  WebFontConfig = {"google":{"families":["Alegreya+Sans:100:latin,latin-ext","Alegreya+Sans:r,i,b,bi:latin,latin-ext"]}};
  (function() {
    var wf = document.createElement('script');
    wf.src = 'https://s0.wp.com/wp-content/plugins/custom-fonts/js/webfont.js';
    wf.type = 'text/javascript';
    wf.async = 'true';
    var s = document.getElementsByTagName('script')[0];
    s.parentNode.insertBefore(wf, s);
	})();
</script><style id="jetpack-custom-fonts-css">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</style>
<meta name="google-site-verification" content="dCeFF4cS2CniA7__gVcesHUF0tTOKtGK7xJTBSndP5M" />
<meta name="p:domain_verify" content="b7990ef1517df9310a32ac6f6ea58faa" />
		<script src='https://r-login.wordpress.com/remote-login.php?action=js&amp;host=haathitime.com&amp;id=23578026&amp;t=1539620503&amp;back=https%3A%2F%2Fhaathitime.com%2F2018%2F10%2F15%2Fday-288-all-along-this-love-was-right-in-front-of-me%2F' type="text/javascript"></script>
		<script type="text/javascript">
		/* <![CDATA[ */
			if ( 'function' === typeof WPRemoteLogin ) {
				document.cookie = "wordpress_test_cookie=test; path=/";
				if ( document.cookie.match( /(;|^)\s*wordpress_test_cookie\=/ ) ) {
					WPRemoteLogin();
				}
			}
		/* ]]> */
		</script>
		<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//haathitime.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.pubmine.com' />
<link rel='dns-prefetch' href='//x.bidswitch.net' />
<link rel='dns-prefetch' href='//static.criteo.net' />
<link rel='dns-prefetch' href='//ib.adnxs.com' />
<link rel='dns-prefetch' href='//aax.amazon-adsystem.com' />
<link rel='dns-prefetch' href='//bidder.criteo.com' />
<link rel='dns-prefetch' href='//cas.criteo.com' />
<link rel='dns-prefetch' href='//gum.criteo.com' />
<link rel='dns-prefetch' href='//ads.pubmatic.com' />
<link rel='dns-prefetch' href='//gads.pubmatic.com' />
<link rel='dns-prefetch' href='//tpc.googlesyndication.com' />
<link rel='dns-prefetch' href='//ad.doubleclick.net' />
<link rel='dns-prefetch' href='//googleads.g.doubleclick.net' />
<link rel='dns-prefetch' href='//www.googletagservices.com' />
<link rel='dns-prefetch' href='//cdn.switchadhub.com' />
<link rel='dns-prefetch' href='//delivery.g.switchadhub.com' />
<link rel='dns-prefetch' href='//delivery.swid.switchadhub.com' />
<link rel="alternate" type="application/rss+xml" title=" &raquo; Feed" href="https://haathitime.com/feed/" />
<link rel="alternate" type="application/rss+xml" title=" &raquo; Comments Feed" href="https://haathitime.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title=" &raquo; Day 288: All along this love was right in front of&nbsp;me Comments Feed" href="https://haathitime.com/2018/10/15/day-288-all-along-this-love-was-right-in-front-of-me/feed/" />
	<script type="text/javascript">
		/* <![CDATA[ */
		function addLoadEvent(func) {
			var oldonload = window.onload;
			if (typeof window.onload != 'function') {
				window.onload = func;
			} else {
				window.onload = function () {
					oldonload();
					func();
				}
			}
		}
		/* ]]> */
	</script>
			<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/s1.wp.com\/wp-includes\/js\/wp-emoji-release.min.js?m=1532082729h&ver=4.9.8"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='all-css-0-1' href='https://s1.wp.com/_static/??-eJyFkOtOwzAMhV+IYC6F/UI8Sy6my2Y3UezS7e1xV5jGJnV/Itv6js+JYaoulkFxUODRVRr7PAhQ3qPADrX6uHen7jGKPMAFHqj0Z8FUWvJJoKcSPN2wF6sbkldMrhbRq25NFktDm3P1OhOMKXskZMPWZFNOPZqPIb+1UzysSri+/xnN5dYusJpsqka7EGpDEWcv55Gdbi3bnR/xnH657ingv8kizTAUzaaWc3Gzc7GCOgag8o2x+S8F0SPhjH7yx/Pb62bTvXTd0+4HUua6FA==?cssminify=yes' type='text/css' media='all' />
<style id='lovecraft-style-inline-css' type='text/css'>
 { clip: rect(1px, 1px, 1px, 1px); height: 1px; position: absolute; overflow: hidden; width: 1px; }
</style>
<link rel='stylesheet' id='lovecraft-fonts-css'  href='https://fonts.googleapis.com/css?family=Playfair+Display%3A400%2C700%2C400italic%7CLato%3A400%2C400italic%2C700%2C700italic%2C900%2C900italic&#038;subset=latin%2Clatin-ext&#038;ver=4.9.8' type='text/css' media='all' />
<link rel='stylesheet' id='all-css-2-1' href='https://s1.wp.com/_static/??-eJyVj0EOAiEMRS8kNqPjuDKeBbGDaKFkKBJvL+oGY5zo7r/8vjaFEpXhIBgEfFaRsnUhgcWAk6vFl7g0KS2gceWEHhPEfADiK5pJjwIuGEhyI1QlGvYfUnOwuKNFSSAcVeRU01P8RcFcW744VKQLCPpIWvCPBYmN06ReP7YwJ1tkRWy0OA5voEbSbppTJzwQ2xot1KkGH9Le77rNajus+64fznfoppx2?cssminify=yes' type='text/css' media='all' />
<link rel='stylesheet' id='print-css-3-1' href='https://s2.wp.com/wp-content/mu-plugins/global-print/global-print.css?m=1465851035h&cssminify=yes' type='text/css' media='print' />
<link rel='stylesheet' id='all-css-4-1' href='https://s0.wp.com/_static/??-eJx9i0EKQjEMBS9kDdVfXIlnyS+1jaRJafLx+uJCRBRXbx7MwH2ErOJFHPoWBm+VxACzk8qK8037bLaD3/pQ83BlpAnWcJLU1/6rTDMhB9aqn+cr8lZ6MWgLVNYV+Slc+jmmQzrFtMTj7QHFQEmu?cssminify=yes' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??-eJyFj90KwjAMhV/IrAw6xQvxWWoXS2r/bNoNfXo70At1KARCTr4cTsScgIJ2dUQWttW1Yr49W2d5I34B4MlkVbDzFF6wjqFgKAvr44kcQmXMyjStGZ3jCpciF4/MDVrZvkeiMBHOfzGLJSl9gYxM9y9XXyG5aiiwyOjaAyMsGT6mdnX0h17uh36Qcre1DyuucHk='></script>
<link rel='stylesheet' id='all-css-0-2' href='https://s0.wp.com/wp-content/mu-plugins/highlander-comments/style.css?m=1530132353h&cssminify=yes' type='text/css' media='all' />
<!--[if lt IE 8]>
<link rel='stylesheet' id='highlander-comments-ie7-css'  href='https://s2.wp.com/wp-content/mu-plugins/highlander-comments/style-ie7.css?m=1351637563h&#038;ver=20110606' type='text/css' media='all' />
<![endif]-->
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://haathitime.wordpress.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://s1.wp.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Day 285: They&#8217;ll be making sure you stay&nbsp;amused' href='https://haathitime.com/2018/10/12/day-285-theyll-be-making-sure-you-stay-amused/' />
<meta name="generator" content="WordPress.com" />
<link rel="canonical" href="https://haathitime.com/2018/10/15/day-288-all-along-this-love-was-right-in-front-of-me/" />
<link rel='shortlink' href='https://wp.me/p1AVIK-2SG' />
<link rel="alternate" type="application/json+oembed" href="https://public-api.wordpress.com/oembed/?format=json&amp;url=https%3A%2F%2Fhaathitime.com%2F2018%2F10%2F15%2Fday-288-all-along-this-love-was-right-in-front-of-me%2F&amp;for=wpcom-auto-discovery" /><link rel="alternate" type="application/xml+oembed" href="https://public-api.wordpress.com/oembed/?format=xml&amp;url=https%3A%2F%2Fhaathitime.com%2F2018%2F10%2F15%2Fday-288-all-along-this-love-was-right-in-front-of-me%2F&amp;for=wpcom-auto-discovery" />
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Day 288: All along this love was right in front of me" />
<meta property="og:url" content="https://haathitime.com/2018/10/15/day-288-all-along-this-love-was-right-in-front-of-me/" />
<meta property="og:description" content="Today has been such a slow day. This feeling of everything being tentative seems to pervade every where, across spheres of my life. The only thing that&#8217;s moving ahead with sprightly energy is…" />
<meta property="article:published_time" content="2018-10-15T15:53:53+00:00" />
<meta property="article:modified_time" content="2018-10-15T16:00:05+00:00" />
<meta property="og:image" content="https://haathitime.files.wordpress.com/2018/10/img_7229.jpg" />
<meta property="og:image:width" content="1024" />
<meta property="og:image:height" content="1024" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:creator" content="@haathitime" />
<meta name="twitter:site" content="@haathitime" />
<meta name="twitter:text:title" content="Day 288: All along this love was right in front of&nbsp;me" />
<meta name="twitter:card" content="summary" />
<meta property="article:publisher" content="https://www.facebook.com/WordPresscom" />

<!-- End Jetpack Open Graph Tags -->
<link rel="shortcut icon" type="image/x-icon" href="https://s1.wp.com/i/favicon.ico" sizes="16x16 24x24 32x32 48x48" />
<link rel="icon" type="image/x-icon" href="https://s1.wp.com/i/favicon.ico" sizes="16x16 24x24 32x32 48x48" />
<link rel="apple-touch-icon-precomposed" href="https://s2.wp.com/i/webclip.png" />
<link rel='openid.server' href='https://haathitime.wordpress.com/?openidserver=1' />
<link rel='openid.delegate' href='https://haathitime.wordpress.com/' />
<link rel="search" type="application/opensearchdescription+xml" href="https://haathitime.com/osd.xml" title="" />
<link rel="search" type="application/opensearchdescription+xml" href="https://s1.wp.com/opensearch.xml" title="WordPress.com" />
<meta name="theme-color" content="#fafafa" />
		<style type="text/css">
			.recentcomments a {
				display: inline !important;
				padding: 0 !important;
				margin: 0 !important;
			}

			table.recentcommentsavatartop img.avatar, table.recentcommentsavatarend img.avatar {
				border: 0px;
				margin: 0;
			}

			table.recentcommentsavatartop a, table.recentcommentsavatarend a {
				border: 0px !important;
				background-color: transparent !important;
			}

			td.recentcommentsavatarend, td.recentcommentsavatartop {
				padding: 0px 0px 1px 0px;
				margin: 0px;
			}

			td.recentcommentstextend {
				border: none !important;
				padding: 0px 0px 2px 10px;
			}

			.rtl td.recentcommentstextend {
				padding: 0px 10px 2px 0px;
			}

			td.recentcommentstexttop {
				border: none;
				padding: 0px 0px 0px 10px;
			}

			.rtl td.recentcommentstexttop {
				padding: 0px 10px 0px 0px;
			}
		</style>
		<meta name="application-name" content="WordPress.com" /><meta name="msapplication-window" content="width=device-width;height=device-height" /><meta name="msapplication-task" content="name=Subscribe;action-uri=https://haathitime.com/feed/;icon-uri=https://s1.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=Sign up for a free blog;action-uri=http://wordpress.com/signup/;icon-uri=https://s1.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=WordPress.com Support;action-uri=http://support.wordpress.com/;icon-uri=https://s1.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=WordPress.com Forums;action-uri=http://forums.wordpress.com/;icon-uri=https://s1.wp.com/i/favicon.ico" /><meta name="description" content="Today has been such a slow day. This feeling of everything being tentative seems to pervade every where, across spheres of my life. The only thing that&#039;s moving ahead with sprightly energy is my presence and activity around home. Thanks to Niyu being with us, recovering slowly, the workings of my home have fallen into&hellip;" />
		<script type="text/javascript">
		function __ATA_CC() {var v = document.cookie.match('(^|;) ?personalized-ads-consent=([^;]*)(;|$)');return v ? 1 : 0;}
		var __ATA_PP = { pt: 1, ht: 1, tn: 'lovecraft', amp: false, siteid: 23578026, consent: __ATA_CC() };
		var __ATA = __ATA || {};
		__ATA.cmd = __ATA.cmd || [];
		__ATA.criteo = __ATA.criteo || {};
		__ATA.criteo.cmd = __ATA.criteo.cmd || [];
		</script>
		<script type="text/javascript" src="//s.pubmine.com/head.js" async></script><link rel="amphtml" href="https://haathitime.com/2018/10/15/day-288-all-along-this-love-was-right-in-front-of-me/amp/"><style type="text/css" id="syntaxhighlighteranchor"></style>
<style type="text/css" id="custom-colors-css">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</style>
</head>

<body class="post-template-default single single-post postid-11078 single-format-standard mp6 customizer-styles-applied highlander-enabled highlander-light">
<div id="page" class="hfeed site">
	<a class="skip-link screen-reader-text" href="#content">Skip to content</a>

	<header id="masthead" class="site-header" role="banner">
		<div class="site-branding">
													<h1 class="site-title"><a href="https://haathitime.com/" rel="home"></a></h1>
			<p class="site-description"></p>
		</div><!-- .site-branding -->

		<div class="toggles clear">
			<button class="menu-toggle toggle" aria-controls="primary-menu" aria-expanded="false">
				<div class="bar"></div>
				<div class="bar"></div>
				<div class="bar"></div>
				<span class="screen-reader-text">Menu</span>
			</button><!-- .menu-toggle -->
			<button class="search-toggle toggle">
				<div class="genericon genericon-search" aria-expanded="false">
					<span class="screen-reader-text">Search</span>
				</div><!-- .genericon-search -->
			</button><!-- .search-toggle -->
		</div><!-- .toggles -->

		<nav id="site-navigation" class="main-navigation" role="navigation">
			<div id="primary-menu" class="menu"><ul>
<li class="page_item page-item-2610"><a href="https://haathitime.com/eitheror/">About</a></li>
<li class="page_item page-item-3422"><a href="https://haathitime.com/talk-to-me/">Get in touch</a></li>
<li class="page_item page-item-9813"><a href="https://haathitime.com/newsletter/">Newsletter</a></li>
</ul></div>
		</nav><!-- #site-navigation -->

		<div class="mobile-search">
			<form role="search" method="get" class="search-form" action="https://haathitime.com/">
	<label>
		<span class="screen-reader-text">Search for:</span>
		<input type="search" class="search-field" placeholder="Search …" value="" name="s" title="Search for:" />
	</label>
	<button type="submit" class="search-submit">
		<span class="genericon genericon-search">
			<span class="screen-reader-text">Search</span>
		</span>
	</button>
</form>		</div>
	</header><!-- #masthead -->

			<a class="header-image-wrapper" href="https://haathitime.com/" rel="home">
			<div class="header-image bg-image" style="background-image: url(https://haathitime.files.wordpress.com/2018/01/cropped-ha1.jpg)">
				<img src="https://haathitime.files.wordpress.com/2018/01/cropped-ha1.jpg" width="1280" height="442" alt="">
			</div>
		</a>
	
	<div id="content" class="site-content">

	<div id="primary" class="content-area">
		<main id="main" class="site-main" role="main">

		
			
<article id="post-11078" class="post-11078 post type-post status-publish format-standard hentry category-life-and-times tag-gratitude tag-life-in-bangalore tag-love-and-longing tag-my-family-and-other-animals tag-photographs">
	<div class="entry-wrapper">
		<header class="entry-header">
			<h1 class="entry-title">Day 288: All along this love was right in front of&nbsp;me</h1>
							<div class="entry-meta">
					<span class="posted-on">On <a href="https://haathitime.com/2018/10/15/day-288-all-along-this-love-was-right-in-front-of-me/" rel="bookmark"><time class="entry-date published" datetime="2018-10-15T21:23:53+00:00">October 15, 2018</time><time class="updated" datetime="2018-10-15T21:30:05+00:00">October 15, 2018</time></a></span><span class="byline"> By <span class="author vcard"><a class="url fn n" href="https://haathitime.com/author/haathitime/">hAAthi</a></span></span>				</div><!-- .entry-meta -->
					</header><!-- .entry-header -->

		<div class="entry-content">
			<p><img data-attachment-id="11079" data-permalink="https://haathitime.com/2018/10/15/day-288-all-along-this-love-was-right-in-front-of-me/img_7229/" data-orig-file="https://haathitime.files.wordpress.com/2018/10/img_7229.jpg?w=640" data-orig-size="1024,1024" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="img_7229" data-image-description="" data-medium-file="https://haathitime.files.wordpress.com/2018/10/img_7229.jpg?w=640?w=300" data-large-file="https://haathitime.files.wordpress.com/2018/10/img_7229.jpg?w=640?w=640" src="https://haathitime.files.wordpress.com/2018/10/img_7229.jpg?w=640" class="wp-image-11079 size-full" srcset="https://haathitime.files.wordpress.com/2018/10/img_7229.jpg?w=640 640w, https://haathitime.files.wordpress.com/2018/10/img_7229.jpg?w=150 150w, https://haathitime.files.wordpress.com/2018/10/img_7229.jpg?w=300 300w, https://haathitime.files.wordpress.com/2018/10/img_7229.jpg?w=768 768w, https://haathitime.files.wordpress.com/2018/10/img_7229.jpg 1024w" sizes="(max-width: 640px) 100vw, 640px"  ></p>
<p>Today has been such a slow day. This feeling of everything being tentative seems to pervade every where, across spheres of my life. The only thing that&#8217;s moving ahead with sprightly energy is my presence and activity around home. Thanks to Niyu being with us, recovering slowly, the workings of my home have fallen into a healthy clockwork pattern which has brought about a sense of grounding for me.</p>
<p>I&#8217;m deeply grateful for this. It&#8217;s hard to look at difficult times (the last ten days have been hectic and stretched us all in ways unimaginable) and feel gratitude for unseen gifts. But this is the truth, hard as it is to accept, there have been positive aspects to it. We got the gift of focused family time. I was thrust into a role of caregiver that has skyrocketed my respect and gratitude for the role my mother plays in our lives, I see the men in my life (VC and my dad) in a very different light, and there has been the gift of a home that works like a home again.</p>
<p><em>Two years ago: <a href="https://haathitime.com/2016/10/14/day-288-new-eyes/" target="_blank" rel="noopener">Day 288: New eyes</a></em></p>
		<div class="wpcnt">
			<div class="wpa wpmrec">
				<span class="wpa-about">Advertisements</span>
				<div class="u">		<div style="padding-bottom:15px;width:300px;height:250px;float:left;margin-right:5px;margin-top:0px">
		<div id="atatags-235780261-5bc4be9759850">
			<script type="text/javascript">
			__ATA.cmd.push(function() {
				__ATA.initSlot('atatags-235780261-5bc4be9759850',  {
					collapseEmpty: 'before',
					sectionId: '235780261',
					width: 300,
					height: 250
				});
			});
			</script>
		</div></div>		<div style="padding-bottom:15px;width:300px;height:250px;float:left;margin-top:0px">
		<div id="atatags-235780264-5bc4be9759853">
			<script type="text/javascript">
			__ATA.cmd.push(function() {
				__ATA.initSlot('atatags-235780264-5bc4be9759853',  {
					collapseEmpty: 'before',
					sectionId: '235780264',
					width: 300,
					height: 250
				});
			});
			</script>
		</div></div></div>
				
			</div>
		</div><div id="atatags-235780265-5bc4be9759888">
        <script type="text/javascript">
            __ATA.cmd.push(function() {
                __ATA.initVideoSlot('atatags-235780265-5bc4be9759888', {
                    sectionId: '235780265',
                    format: 'inread'
                });
            });
        </script>
    </div><div id="jp-post-flair" class="sharedaddy sd-like-enabled sd-sharing-enabled"><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share now!</h3><div class="sd-content"><ul><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button share-icon no-text" href="https://haathitime.com/2018/10/15/day-288-all-along-this-love-was-right-in-front-of-me/?share=email" target="_blank" title="Click to email this to a friend"><span></span><span class="sharing-screen-reader-text">Click to email this to a friend (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-11078" class="share-twitter sd-button share-icon no-text" href="https://haathitime.com/2018/10/15/day-288-all-along-this-love-was-right-in-front-of-me/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-11078" class="share-facebook sd-button share-icon no-text" href="https://haathitime.com/2018/10/15/day-288-all-along-this-love-was-right-in-front-of-me/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-pinterest"><a rel="nofollow noopener noreferrer" data-shared="sharing-pinterest-11078" class="share-pinterest sd-button share-icon no-text" href="https://haathitime.com/2018/10/15/day-288-all-along-this-love-was-right-in-front-of-me/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span></span><span class="sharing-screen-reader-text">Click to share on Pinterest (Opens in new window)</span></a></li><li class="share-jetpack-whatsapp"><a rel="nofollow noopener noreferrer" data-shared="" class="share-jetpack-whatsapp sd-button share-icon no-text" href="https://api.whatsapp.com/send?text=Day%20288%3A%20All%20along%20this%20love%20was%20right%20in%20front%20of%20me%20https%3A%2F%2Fhaathitime.com%2F2018%2F10%2F15%2Fday-288-all-along-this-love-was-right-in-front-of-me%2F" target="_blank" title="Click to share on WhatsApp"><span></span><span class="sharing-screen-reader-text">Click to share on WhatsApp (Opens in new window)</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-11078" class="share-linkedin sd-button share-icon no-text" href="https://haathitime.com/2018/10/15/day-288-all-along-this-love-was-right-in-front-of-me/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span></span><span class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li class="share-pocket"><a rel="nofollow noopener noreferrer" data-shared="" class="share-pocket sd-button share-icon no-text" href="https://haathitime.com/2018/10/15/day-288-all-along-this-love-was-right-in-front-of-me/?share=pocket" target="_blank" title="Click to share on Pocket"><span></span><span class="sharing-screen-reader-text">Click to share on Pocket (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-23578026-11078-5bc4be975a561' data-src='//widgets.wp.com/likes/index.html?ver=20180319#blog_id=23578026&amp;post_id=11078&amp;origin=haathitime.wordpress.com&amp;obj_id=23578026-11078-5bc4be975a561' data-name='like-post-frame-23578026-11078-5bc4be975a561'><h3 class='sd-title'>Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div></div>					</div><!-- .entry-content -->

		<footer class="entry-footer">
			<span class="tags-links"><a href="https://haathitime.com/tag/gratitude/" rel="tag">Gratitude</a><a href="https://haathitime.com/tag/life-in-bangalore/" rel="tag">Life in Bangalore</a><a href="https://haathitime.com/tag/love-and-longing/" rel="tag">Love and longing</a><a href="https://haathitime.com/tag/my-family-and-other-animals/" rel="tag">My family and other animals</a><a href="https://haathitime.com/tag/photographs/" rel="tag">Photographs</a></span>					</footer><!-- .entry-footer -->
	</div>
</article><!-- #post-## -->


			
	<nav class="navigation post-navigation" role="navigation">
		<h2 class="screen-reader-text">Post navigation</h2>
		<div class="nav-links"><div class="nav-previous"><a href="https://haathitime.com/2018/10/12/day-285-theyll-be-making-sure-you-stay-amused/" rel="prev"><span class="meta-nav">Previous</span> <h4>Day 285: They&#8217;ll be making sure you stay&nbsp;amused</h4></a></div></div>
	</nav>
			
<div id="comments" class="comments-area">
	<div class="comments-wrapper">
		
		
		
			<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Pour your thoughts over mine <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2018/10/15/day-288-all-along-this-love-was-right-in-front-of-me/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="https://haathitime.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate>
				<input type="hidden" id="highlander_comment_nonce" name="highlander_comment_nonce" value="8fd63a5a4d" /><input type="hidden" name="_wp_http_referer" value="/2018/10/15/day-288-all-along-this-love-was-right-in-front-of-me/" />
<input type="hidden" name="hc_post_as" id="hc_post_as" value="guest" />

<div class="comment-form-field comment-textarea">
	<label for="comment">Enter your comment here...</label>
	<div id="comment-form-comment"><textarea id="comment" name="comment" title="Enter your comment here..."></textarea></div>
</div>

<div id="comment-form-identity">
	<div id="comment-form-nascar">
		<p>Fill in your details below or click an icon to log in:</p>
		<ul>
			<li class="selected" style="display:none;">
				<a href="#comment-form-guest" id="postas-guest" class="nascar-signin-link"
                   title="Login via Guest">
									</a>
			</li>
			<li>
				<a href="#comment-form-load-service:WordPress.com" id="postas-wordpress" class="nascar-signin-link"
                   title="Login via WordPress.com">
					<svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#0087be" d="M12.158 12.786l-2.698 7.84c.806.236 1.657.365 2.54.365 1.047 0 2.05-.18 2.986-.51-.024-.037-.046-.078-.065-.123l-2.762-7.57zM3.008 12c0 3.56 2.07 6.634 5.068 8.092L3.788 8.342c-.5 1.117-.78 2.354-.78 3.658zm15.06-.454c0-1.112-.398-1.88-.74-2.48-.456-.74-.883-1.368-.883-2.11 0-.825.627-1.595 1.51-1.595.04 0 .078.006.116.008-1.598-1.464-3.73-2.36-6.07-2.36-3.14 0-5.904 1.613-7.512 4.053.21.008.41.012.58.012.94 0 2.395-.114 2.395-.114.484-.028.54.684.057.74 0 0-.487.058-1.03.086l3.275 9.74 1.968-5.902-1.4-3.838c-.485-.028-.944-.085-.944-.085-.486-.03-.43-.77.056-.742 0 0 1.484.114 2.368.114.94 0 2.397-.114 2.397-.114.486-.028.543.684.058.74 0 0-.488.058-1.03.086l3.25 9.665.897-2.997c.456-1.17.684-2.137.684-2.907zm1.82-3.86c.04.286.06.593.06.924 0 .912-.17 1.938-.683 3.22l-2.746 7.94c2.672-1.558 4.47-4.454 4.47-7.77 0-1.564-.4-3.033-1.1-4.314zM12 22C6.486 22 2 17.514 2 12S6.486 2 12 2s10 4.486 10 10-4.486 10-10 10z"/></g></svg>				</a>
			</li>
			<li>
			<li>
				<a href="#comment-form-load-service:Twitter" id="postas-twitter" class="nascar-signin-link"
                   title="Login via Twitter">
					<svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#1DA1F2" d="M22.23 5.924c-.736.326-1.527.547-2.357.646.847-.508 1.498-1.312 1.804-2.27-.793.47-1.67.812-2.606.996C18.325 4.498 17.258 4 16.078 4c-2.266 0-4.103 1.837-4.103 4.103 0 .322.036.635.106.935-3.41-.17-6.433-1.804-8.457-4.287-.353.607-.556 1.312-.556 2.064 0 1.424.724 2.68 1.825 3.415-.673-.022-1.305-.207-1.86-.514v.052c0 1.988 1.415 3.647 3.293 4.023-.344.095-.707.145-1.08.145-.265 0-.522-.026-.773-.074.522 1.63 2.038 2.817 3.833 2.85-1.404 1.1-3.174 1.757-5.096 1.757-.332 0-.66-.02-.98-.057 1.816 1.164 3.973 1.843 6.29 1.843 7.547 0 11.675-6.252 11.675-11.675 0-.178-.004-.355-.012-.53.802-.578 1.497-1.3 2.047-2.124z"/></g></svg>				</a>
			</li>
			<li>
				<a href="#comment-form-load-service:Facebook" id="postas-facebook" class="nascar-signin-link"
                   title="Login via Facebook">
					<svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#3B5998" d="M20.007 3H3.993C3.445 3 3 3.445 3 3.993v16.013c0 .55.445.994.993.994h8.62v-6.97H10.27V11.31h2.346V9.31c0-2.325 1.42-3.59 3.494-3.59.993 0 1.847.073 2.096.106v2.43h-1.438c-1.128 0-1.346.537-1.346 1.324v1.734h2.69l-.35 2.717h-2.34V21h4.587c.548 0 .993-.445.993-.993V3.993c0-.548-.445-.993-.993-.993z"/></g></svg>				</a>
			</li>
		</ul>
	</div>

	<div id="comment-form-guest" class="comment-form-service selected">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
<a href="https://gravatar.com/site/signup/" target="_blank">				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y&amp;r=G" alt="Gravatar" width="25" class="no-grav" />
</a>			</div>

				<div class="comment-form-fields">
				<div class="comment-form-field comment-form-email">
					<label for="email">Email <span class="required">(required)</span> <span class="nopublish">(Address never made public)</span></label>
					<div class="comment-form-input"><input id="email" name="email" type="email" value="" /></div>
				</div>
				<div class="comment-form-field comment-form-author">
					<label for="author">Name <span class="required">(required)</span></label>
					<div class="comment-form-input"><input id="author" name="author" type="text" value="" /></div>
				</div>
				<div class="comment-form-field comment-form-url">
					<label for="url">Website</label>
					<div class="comment-form-input"><input id="url" name="url" type="url" value="" /></div>
				</div>
			</div>
			
		</div>
	</div>

	<div id="comment-form-wordpress" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y&amp;r=G" alt="WordPress.com Logo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="wp_avatar" id="wordpress-avatar" class="comment-meta-wordpress" value="" />
				<input type="hidden" name="wp_user_id" id="wordpress-user_id" class="comment-meta-wordpress" value="" />
				<input type="hidden" name="wp_access_token" id="wordpress-access_token" class="comment-meta-wordpress" value="" />
						<p class="comment-form-posting-as pa-wordpress">
			<strong></strong>
			You are commenting using your WordPress.com account.			<span class="comment-form-log-out">
				(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'wordpress' );">Log&nbsp;Out</a>&nbsp;/&nbsp;
				<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)
			</span>
			<span class="pa-icon"><svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#0087be" d="M12.158 12.786l-2.698 7.84c.806.236 1.657.365 2.54.365 1.047 0 2.05-.18 2.986-.51-.024-.037-.046-.078-.065-.123l-2.762-7.57zM3.008 12c0 3.56 2.07 6.634 5.068 8.092L3.788 8.342c-.5 1.117-.78 2.354-.78 3.658zm15.06-.454c0-1.112-.398-1.88-.74-2.48-.456-.74-.883-1.368-.883-2.11 0-.825.627-1.595 1.51-1.595.04 0 .078.006.116.008-1.598-1.464-3.73-2.36-6.07-2.36-3.14 0-5.904 1.613-7.512 4.053.21.008.41.012.58.012.94 0 2.395-.114 2.395-.114.484-.028.54.684.057.74 0 0-.487.058-1.03.086l3.275 9.74 1.968-5.902-1.4-3.838c-.485-.028-.944-.085-.944-.085-.486-.03-.43-.77.056-.742 0 0 1.484.114 2.368.114.94 0 2.397-.114 2.397-.114.486-.028.543.684.058.74 0 0-.488.058-1.03.086l3.25 9.665.897-2.997c.456-1.17.684-2.137.684-2.907zm1.82-3.86c.04.286.06.593.06.924 0 .912-.17 1.938-.683 3.22l-2.746 7.94c2.672-1.558 4.47-4.454 4.47-7.77 0-1.564-.4-3.033-1.1-4.314zM12 22C6.486 22 2 17.514 2 12S6.486 2 12 2s10 4.486 10 10-4.486 10-10 10z"/></g></svg></span>
		</p>
					</div>
	
		</div>
	</div>

	<div id="comment-form-googleplus" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y&amp;r=G" alt="Google+ photo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="googleplus_avatar" id="googleplus-avatar" class="comment-meta-googleplus" value="" />
				<input type="hidden" name="googleplus_user_id" id="googleplus-user_id" class="comment-meta-googleplus" value="" />
				<input type="hidden" name="googleplus_access_token" id="googleplus-access_token" class="comment-meta-googleplus" value="" />
						<p class="comment-form-posting-as pa-googleplus">
			<strong></strong>
			You are commenting using your Google+ account.			<span class="comment-form-log-out">
				(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'googleplus' );">Log&nbsp;Out</a>&nbsp;/&nbsp;
				<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)
			</span>
			<span class="pa-icon"><svg xmlns="http://www.w3.org/2000/svg" role="presentation" x="0px" y="0px" viewBox="0 0 60 60" ><path fill="#519bf7" d="M56.3,30c0,-1.6 -0.2,-3.4 -0.6,-5h-3.1H42.2H30v10.6h14.8C44,39.3 42,42 39.1,43.9l8.8,6.8C53,46 56.3,39 56.3,30z" /><path fill="#3db366" d="M30,57.5c6.7,0 13.1,-2.4 17.9,-6.8l-8.8,-6.8c-2.5,1.6 -5.6,2.4 -9.1,2.4c-7.2,0 -13.3,-4.7 -15.4,-11.2l-9.3,7.1C9.8,51.3 19.1,57.5 30,57.5z" /><path fill="#fdc600" d="M5.3,42.2l9.3,-7.1c-0.5,-1.6 -0.8,-3.3 -0.8,-5.1s0.3,-3.5 0.8,-5.1l-9.3,-7.1C3.5,21.5 2.5,25.6 2.5,30S3.5,38.5 5.3,42.2z" /><path fill="#f15b44" d="M40.1,17.4l8,-8C43.3,5.1 37,2.5 30,2.5C19.1,2.5 9.8,8.7 5.3,17.8l9.3,7.1c2.1,-6.5 8.2,-11.1 15.4,-11.1C33.9,13.7 37.4,15.1 40.1,17.4z" /></svg></span>
		</p>
					</div>
	
		</div>
	</div>

	<div id="comment-form-twitter" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y&amp;r=G" alt="Twitter picture" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="twitter_avatar" id="twitter-avatar" class="comment-meta-twitter" value="" />
				<input type="hidden" name="twitter_user_id" id="twitter-user_id" class="comment-meta-twitter" value="" />
				<input type="hidden" name="twitter_access_token" id="twitter-access_token" class="comment-meta-twitter" value="" />
						<p class="comment-form-posting-as pa-twitter">
			<strong></strong>
			You are commenting using your Twitter account.			<span class="comment-form-log-out">
				(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'twitter' );">Log&nbsp;Out</a>&nbsp;/&nbsp;
				<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)
			</span>
			<span class="pa-icon"><svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#1DA1F2" d="M22.23 5.924c-.736.326-1.527.547-2.357.646.847-.508 1.498-1.312 1.804-2.27-.793.47-1.67.812-2.606.996C18.325 4.498 17.258 4 16.078 4c-2.266 0-4.103 1.837-4.103 4.103 0 .322.036.635.106.935-3.41-.17-6.433-1.804-8.457-4.287-.353.607-.556 1.312-.556 2.064 0 1.424.724 2.68 1.825 3.415-.673-.022-1.305-.207-1.86-.514v.052c0 1.988 1.415 3.647 3.293 4.023-.344.095-.707.145-1.08.145-.265 0-.522-.026-.773-.074.522 1.63 2.038 2.817 3.833 2.85-1.404 1.1-3.174 1.757-5.096 1.757-.332 0-.66-.02-.98-.057 1.816 1.164 3.973 1.843 6.29 1.843 7.547 0 11.675-6.252 11.675-11.675 0-.178-.004-.355-.012-.53.802-.578 1.497-1.3 2.047-2.124z"/></g></svg></span>
		</p>
					</div>
	
		</div>
	</div>

	<div id="comment-form-facebook" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y&amp;r=G" alt="Facebook photo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="fb_avatar" id="facebook-avatar" class="comment-meta-facebook" value="" />
				<input type="hidden" name="fb_user_id" id="facebook-user_id" class="comment-meta-facebook" value="" />
				<input type="hidden" name="fb_access_token" id="facebook-access_token" class="comment-meta-facebook" value="" />
						<p class="comment-form-posting-as pa-facebook">
			<strong></strong>
			You are commenting using your Facebook account.			<span class="comment-form-log-out">
				(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'facebook' );">Log&nbsp;Out</a>&nbsp;/&nbsp;
				<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)
			</span>
			<span class="pa-icon"><svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#3B5998" d="M20.007 3H3.993C3.445 3 3 3.445 3 3.993v16.013c0 .55.445.994.993.994h8.62v-6.97H10.27V11.31h2.346V9.31c0-2.325 1.42-3.59 3.494-3.59.993 0 1.847.073 2.096.106v2.43h-1.438c-1.128 0-1.346.537-1.346 1.324v1.734h2.69l-.35 2.717h-2.34V21h4.587c.548 0 .993-.445.993-.993V3.993c0-.548-.445-.993-.993-.993z"/></g></svg></span>
		</p>
					</div>
	
		</div>
	</div>


	<div id="comment-form-load-service" class="comment-form-service">
		<div class="comment-form-posting-as-cancel"><a href="javascript:HighlanderComments.cancelExternalWindow();">Cancel</a></div>
		<p>Connecting to %s</p>
	</div>

</div>

<script type="text/javascript">
var highlander_expando_javascript = function(){
	var input = document.createElement( 'input' ),
	    comment = jQuery( '#comment' );

	if ( 'placeholder' in input ) {
		comment.attr( 'placeholder', jQuery( '.comment-textarea label' ).remove().text() );
	}

	// Expando Mode: start small, then auto-resize on first click + text length
	jQuery( '#comment-form-identity' ).hide();
	jQuery( '#comment-form-subscribe' ).hide();
	jQuery( '#commentform .form-submit' ).hide();

	comment.css( { 'height':'10px' } ).one( 'focus', function() {
		var timer = setInterval( HighlanderComments.resizeCallback, 10 )
		jQuery( this ).animate( { 'height': HighlanderComments.initialHeight } ).delay( 100 ).queue( function(n) { clearInterval( timer ); HighlanderComments.resizeCallback(); n(); } );
		jQuery( '#comment-form-identity' ).slideDown();
		jQuery( '#comment-form-subscribe' ).slideDown();
		jQuery( '#commentform .form-submit' ).slideDown();
	});
}
jQuery(document).ready( highlander_expando_javascript );
</script>

<div id="comment-form-subscribe">
	<p class="comment-subscription-form"><input type="checkbox" name="subscribe" id="subscribe" value="subscribe" style="width: auto;"/> <label class="subscribe-label" id="subscribe-label" for="subscribe" style="display: inline;">Notify me of new comments via email.</label></p><p class="post-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto;"/> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog"  style="display: inline;">Notify me of new posts via email.</label></p></div>




<p class="form-submit"><input name="submit" type="submit" id="comment-submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='11078' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="d2f292d678" /></p>
<input type="hidden" name="genseq" value="1539620503" />
<p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="33"/></p>			</form>
			</div><!-- #respond -->
	<div style="clear: both"></div><p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p>	</div>
</div><!-- #comments -->

		
		</main><!-- #main -->
	</div><!-- #primary -->


<div id="secondary" class="widget-area" role="complementary">
			<div class="wpcnt">
			<div class="wpa wpmrec">
				<span class="wpa-about">Advertisements</span>
				<div class="u">
							<div style="padding-bottom:15px;width:300px;height:250px;">
		<div id="atatags-235780263-5bc4be975bf46">
			<script type="text/javascript">
			__ATA.cmd.push(function() {
				__ATA.initSlot('atatags-235780263-5bc4be975bf46',  {
					collapseEmpty: 'before',
					sectionId: '235780263',
					width: 300,
					height: 250
				});
			});
			</script>
		</div></div>
				</div>
				
			</div>
		</div><aside id="search-3" class="widget widget_search"><form role="search" method="get" class="search-form" action="https://haathitime.com/">
	<label>
		<span class="screen-reader-text">Search for:</span>
		<input type="search" class="search-field" placeholder="Search …" value="" name="s" title="Search for:" />
	</label>
	<button type="submit" class="search-submit">
		<span class="genericon genericon-search">
			<span class="screen-reader-text">Search</span>
		</span>
	</button>
</form></aside><aside id="media_image-4" class="widget widget_media_image"><style>.widget.widget_media_image { overflow: hidden; }.widget.widget_media_image img { height: auto; max-width: 100%; }</style><a href="https://haathitime.com/eitheror/"><img width="553" height="983" src="https://haathitime.files.wordpress.com/2018/09/snapseed.jpg" class="image wp-image-10859 alignleft attachment-full size-full" alt="" style="max-width: 100%; height: auto;" srcset="https://haathitime.files.wordpress.com/2018/09/snapseed.jpg 553w, https://haathitime.files.wordpress.com/2018/09/snapseed.jpg?w=84&amp;h=150 84w, https://haathitime.files.wordpress.com/2018/09/snapseed.jpg?w=169&amp;h=300 169w" sizes="(max-width: 553px) 100vw, 553px" data-attachment-id="10859" data-permalink="https://haathitime.com/snapseed/" data-orig-file="https://haathitime.files.wordpress.com/2018/09/snapseed.jpg" data-orig-size="553,983" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="snapseed" data-image-description="" data-medium-file="https://haathitime.files.wordpress.com/2018/09/snapseed.jpg?w=169" data-large-file="https://haathitime.files.wordpress.com/2018/09/snapseed.jpg?w=553" /></a></aside><aside id="text-7" class="widget widget_text">			<div class="textwidget"><p>I&#8217;m Revati Upadhya. I live between Bangalore and Goa, and write on food, travel, culture and lifestyle (amongst many other things), for a living. HaathiTime is my personal blog &#8212; a space for me to ruminate about all things big and small.</p>
</div>
		</aside><aside id="custom_html-4" class="widget_text widget widget_custom_html"><h1 class="widget-title">Newsletter</h1><div class="textwidget custom-html-widget"><p>Enter your email address</p><p></p><p><a href="https://tinyletter.com" target="_blank">powered by TinyLetter</a></p></div></aside><aside id="blog_subscription-3" class="widget widget_blog_subscription"><h1 class="widget-title"><label for="subscribe-field">Subscribe!</label></h1>
				<form action="https://subscribe.wordpress.com" method="post" accept-charset="utf-8" id="subscribe-blog">
											<p>Enter your email address to subscribe to this blog and receive notifications of new posts by email.</p>
<p>Join 1,333 other followers</p>
						<p><input type="text" name="email" style="width: 95%; padding: 1px 2px" placeholder="Enter your email address" value="" id="subscribe-field"/></p>
					
					<p>
						<input type="hidden" name="action" value="subscribe"/>
						<input type="hidden" name="blog_id" value="23578026"/>
						<input type="hidden" name="source" value="https://haathitime.com/2018/10/15/day-288-all-along-this-love-was-right-in-front-of-me/"/>
						<input type="hidden" name="sub-type" value="widget"/>
						<input type="hidden" name="redirect_fragment" value="blog_subscription-3" />
						<input type="hidden" id="_wpnonce" name="_wpnonce" value="46afe7539f" />						<input type="submit" value="Sign me up!" />
					</p>
				</form>
			
</aside><aside id="top-posts-3" class="widget widget_top-posts"><h1 class="widget-title">Top posts</h1><ul>				<li>
										<a href="https://haathitime.com/2018/10/12/day-285-theyll-be-making-sure-you-stay-amused/" class="bump-view" data-bump-view="tp">
						Day 285: They&#039;ll be making sure you stay amused					</a>
										</li>
								<li>
										<a href="https://haathitime.com/2018/10/11/day-284-september/" class="bump-view" data-bump-view="tp">
						Day 284: September					</a>
										</li>
								<li>
										<a href="https://haathitime.com/2018/09/08/day-251-its-just-the-nearness-of-you-ten/" class="bump-view" data-bump-view="tp">
						Day 251: It&#039;s just the nearness of you (Ten)					</a>
										</li>
								<li>
										<a href="https://haathitime.com/2018/10/02/day-275-in-the-nick-of-time/" class="bump-view" data-bump-view="tp">
						Day 275: In the nick of time					</a>
										</li>
								<li>
										<a href="https://haathitime.com/2018/10/15/day-288-all-along-this-love-was-right-in-front-of-me/" class="bump-view" data-bump-view="tp">
						Day 288: All along this love was right in front of me					</a>
										</li>
				</ul></aside><aside id="archives-5" class="widget widget_archive"><h1 class="widget-title">Archives</h1>		<label class="screen-reader-text" for="archives-dropdown-5">Archives</label>
		<select id="archives-dropdown-5" name="archive-dropdown" onchange='document.location.href=this.options[this.selectedIndex].value;'>
			
			<option value="">Select Month</option>
				<option value='https://haathitime.com/2018/10/'> October 2018 &nbsp;(11)</option>
	<option value='https://haathitime.com/2018/09/'> September 2018 &nbsp;(25)</option>
	<option value='https://haathitime.com/2018/08/'> August 2018 &nbsp;(25)</option>
	<option value='https://haathitime.com/2018/07/'> July 2018 &nbsp;(24)</option>
	<option value='https://haathitime.com/2018/06/'> June 2018 &nbsp;(23)</option>
	<option value='https://haathitime.com/2018/05/'> May 2018 &nbsp;(28)</option>
	<option value='https://haathitime.com/2018/04/'> April 2018 &nbsp;(23)</option>
	<option value='https://haathitime.com/2018/03/'> March 2018 &nbsp;(24)</option>
	<option value='https://haathitime.com/2018/02/'> February 2018 &nbsp;(22)</option>
	<option value='https://haathitime.com/2018/01/'> January 2018 &nbsp;(24)</option>
	<option value='https://haathitime.com/2017/12/'> December 2017 &nbsp;(6)</option>
	<option value='https://haathitime.com/2017/11/'> November 2017 &nbsp;(3)</option>
	<option value='https://haathitime.com/2017/10/'> October 2017 &nbsp;(14)</option>
	<option value='https://haathitime.com/2017/09/'> September 2017 &nbsp;(9)</option>
	<option value='https://haathitime.com/2017/08/'> August 2017 &nbsp;(3)</option>
	<option value='https://haathitime.com/2017/07/'> July 2017 &nbsp;(7)</option>
	<option value='https://haathitime.com/2017/06/'> June 2017 &nbsp;(5)</option>
	<option value='https://haathitime.com/2017/05/'> May 2017 &nbsp;(1)</option>
	<option value='https://haathitime.com/2017/04/'> April 2017 &nbsp;(5)</option>
	<option value='https://haathitime.com/2017/03/'> March 2017 &nbsp;(3)</option>
	<option value='https://haathitime.com/2017/02/'> February 2017 &nbsp;(4)</option>
	<option value='https://haathitime.com/2017/01/'> January 2017 &nbsp;(8)</option>
	<option value='https://haathitime.com/2016/12/'> December 2016 &nbsp;(23)</option>
	<option value='https://haathitime.com/2016/11/'> November 2016 &nbsp;(23)</option>
	<option value='https://haathitime.com/2016/10/'> October 2016 &nbsp;(21)</option>
	<option value='https://haathitime.com/2016/09/'> September 2016 &nbsp;(22)</option>
	<option value='https://haathitime.com/2016/08/'> August 2016 &nbsp;(23)</option>
	<option value='https://haathitime.com/2016/07/'> July 2016 &nbsp;(21)</option>
	<option value='https://haathitime.com/2016/06/'> June 2016 &nbsp;(24)</option>
	<option value='https://haathitime.com/2016/05/'> May 2016 &nbsp;(24)</option>
	<option value='https://haathitime.com/2016/04/'> April 2016 &nbsp;(22)</option>
	<option value='https://haathitime.com/2016/03/'> March 2016 &nbsp;(24)</option>
	<option value='https://haathitime.com/2016/02/'> February 2016 &nbsp;(21)</option>
	<option value='https://haathitime.com/2016/01/'> January 2016 &nbsp;(24)</option>
	<option value='https://haathitime.com/2015/12/'> December 2015 &nbsp;(2)</option>
	<option value='https://haathitime.com/2015/11/'> November 2015 &nbsp;(3)</option>
	<option value='https://haathitime.com/2015/09/'> September 2015 &nbsp;(6)</option>
	<option value='https://haathitime.com/2015/08/'> August 2015 &nbsp;(3)</option>
	<option value='https://haathitime.com/2015/07/'> July 2015 &nbsp;(1)</option>
	<option value='https://haathitime.com/2015/06/'> June 2015 &nbsp;(2)</option>
	<option value='https://haathitime.com/2015/05/'> May 2015 &nbsp;(3)</option>
	<option value='https://haathitime.com/2015/04/'> April 2015 &nbsp;(4)</option>
	<option value='https://haathitime.com/2015/03/'> March 2015 &nbsp;(1)</option>
	<option value='https://haathitime.com/2015/02/'> February 2015 &nbsp;(1)</option>
	<option value='https://haathitime.com/2015/01/'> January 2015 &nbsp;(5)</option>
	<option value='https://haathitime.com/2014/12/'> December 2014 &nbsp;(15)</option>
	<option value='https://haathitime.com/2014/11/'> November 2014 &nbsp;(5)</option>
	<option value='https://haathitime.com/2014/10/'> October 2014 &nbsp;(9)</option>
	<option value='https://haathitime.com/2014/09/'> September 2014 &nbsp;(21)</option>
	<option value='https://haathitime.com/2014/08/'> August 2014 &nbsp;(2)</option>
	<option value='https://haathitime.com/2014/07/'> July 2014 &nbsp;(7)</option>
	<option value='https://haathitime.com/2014/06/'> June 2014 &nbsp;(5)</option>
	<option value='https://haathitime.com/2014/05/'> May 2014 &nbsp;(10)</option>
	<option value='https://haathitime.com/2014/04/'> April 2014 &nbsp;(8)</option>
	<option value='https://haathitime.com/2014/03/'> March 2014 &nbsp;(14)</option>
	<option value='https://haathitime.com/2014/02/'> February 2014 &nbsp;(4)</option>
	<option value='https://haathitime.com/2014/01/'> January 2014 &nbsp;(9)</option>
	<option value='https://haathitime.com/2013/12/'> December 2013 &nbsp;(5)</option>
	<option value='https://haathitime.com/2013/11/'> November 2013 &nbsp;(8)</option>
	<option value='https://haathitime.com/2013/10/'> October 2013 &nbsp;(10)</option>
	<option value='https://haathitime.com/2013/09/'> September 2013 &nbsp;(5)</option>
	<option value='https://haathitime.com/2013/08/'> August 2013 &nbsp;(8)</option>
	<option value='https://haathitime.com/2013/07/'> July 2013 &nbsp;(7)</option>
	<option value='https://haathitime.com/2013/06/'> June 2013 &nbsp;(8)</option>
	<option value='https://haathitime.com/2013/05/'> May 2013 &nbsp;(15)</option>
	<option value='https://haathitime.com/2013/04/'> April 2013 &nbsp;(14)</option>
	<option value='https://haathitime.com/2013/03/'> March 2013 &nbsp;(20)</option>
	<option value='https://haathitime.com/2013/02/'> February 2013 &nbsp;(13)</option>
	<option value='https://haathitime.com/2013/01/'> January 2013 &nbsp;(21)</option>
	<option value='https://haathitime.com/2012/12/'> December 2012 &nbsp;(16)</option>
	<option value='https://haathitime.com/2012/11/'> November 2012 &nbsp;(17)</option>
	<option value='https://haathitime.com/2012/10/'> October 2012 &nbsp;(17)</option>
	<option value='https://haathitime.com/2012/09/'> September 2012 &nbsp;(16)</option>
	<option value='https://haathitime.com/2012/08/'> August 2012 &nbsp;(19)</option>
	<option value='https://haathitime.com/2012/07/'> July 2012 &nbsp;(17)</option>
	<option value='https://haathitime.com/2012/06/'> June 2012 &nbsp;(19)</option>
	<option value='https://haathitime.com/2012/05/'> May 2012 &nbsp;(13)</option>
	<option value='https://haathitime.com/2012/04/'> April 2012 &nbsp;(9)</option>
	<option value='https://haathitime.com/2012/03/'> March 2012 &nbsp;(20)</option>
	<option value='https://haathitime.com/2012/02/'> February 2012 &nbsp;(14)</option>
	<option value='https://haathitime.com/2012/01/'> January 2012 &nbsp;(17)</option>
	<option value='https://haathitime.com/2011/12/'> December 2011 &nbsp;(10)</option>
	<option value='https://haathitime.com/2011/11/'> November 2011 &nbsp;(17)</option>
	<option value='https://haathitime.com/2011/10/'> October 2011 &nbsp;(12)</option>
	<option value='https://haathitime.com/2011/09/'> September 2011 &nbsp;(12)</option>
	<option value='https://haathitime.com/2011/08/'> August 2011 &nbsp;(11)</option>
	<option value='https://haathitime.com/2011/07/'> July 2011 &nbsp;(20)</option>
	<option value='https://haathitime.com/2011/06/'> June 2011 &nbsp;(26)</option>
	<option value='https://haathitime.com/2011/05/'> May 2011 &nbsp;(12)</option>
	<option value='https://haathitime.com/2011/04/'> April 2011 &nbsp;(19)</option>
	<option value='https://haathitime.com/2011/03/'> March 2011 &nbsp;(16)</option>
	<option value='https://haathitime.com/2011/02/'> February 2011 &nbsp;(8)</option>
	<option value='https://haathitime.com/2011/01/'> January 2011 &nbsp;(11)</option>
	<option value='https://haathitime.com/2010/12/'> December 2010 &nbsp;(18)</option>
	<option value='https://haathitime.com/2010/11/'> November 2010 &nbsp;(32)</option>
	<option value='https://haathitime.com/2010/10/'> October 2010 &nbsp;(20)</option>
	<option value='https://haathitime.com/2010/09/'> September 2010 &nbsp;(25)</option>
	<option value='https://haathitime.com/2010/08/'> August 2010 &nbsp;(20)</option>
	<option value='https://haathitime.com/2010/07/'> July 2010 &nbsp;(13)</option>
	<option value='https://haathitime.com/2010/06/'> June 2010 &nbsp;(22)</option>
	<option value='https://haathitime.com/2010/05/'> May 2010 &nbsp;(27)</option>
	<option value='https://haathitime.com/2010/04/'> April 2010 &nbsp;(14)</option>
	<option value='https://haathitime.com/2010/03/'> March 2010 &nbsp;(16)</option>
	<option value='https://haathitime.com/2010/02/'> February 2010 &nbsp;(12)</option>
	<option value='https://haathitime.com/2010/01/'> January 2010 &nbsp;(10)</option>
	<option value='https://haathitime.com/2009/12/'> December 2009 &nbsp;(7)</option>
	<option value='https://haathitime.com/2009/11/'> November 2009 &nbsp;(2)</option>
	<option value='https://haathitime.com/2009/10/'> October 2009 &nbsp;(12)</option>
	<option value='https://haathitime.com/2009/09/'> September 2009 &nbsp;(8)</option>
	<option value='https://haathitime.com/2009/08/'> August 2009 &nbsp;(14)</option>
	<option value='https://haathitime.com/2009/07/'> July 2009 &nbsp;(11)</option>
	<option value='https://haathitime.com/2009/06/'> June 2009 &nbsp;(14)</option>
	<option value='https://haathitime.com/2009/05/'> May 2009 &nbsp;(14)</option>
	<option value='https://haathitime.com/2009/04/'> April 2009 &nbsp;(24)</option>
	<option value='https://haathitime.com/2009/03/'> March 2009 &nbsp;(26)</option>
	<option value='https://haathitime.com/2009/02/'> February 2009 &nbsp;(27)</option>
	<option value='https://haathitime.com/2009/01/'> January 2009 &nbsp;(21)</option>
	<option value='https://haathitime.com/2008/12/'> December 2008 &nbsp;(16)</option>
	<option value='https://haathitime.com/2008/11/'> November 2008 &nbsp;(4)</option>
	<option value='https://haathitime.com/2008/10/'> October 2008 &nbsp;(2)</option>
	<option value='https://haathitime.com/2008/08/'> August 2008 &nbsp;(3)</option>
	<option value='https://haathitime.com/2008/07/'> July 2008 &nbsp;(4)</option>
	<option value='https://haathitime.com/2008/06/'> June 2008 &nbsp;(2)</option>
	<option value='https://haathitime.com/2008/05/'> May 2008 &nbsp;(1)</option>
	<option value='https://haathitime.com/2008/04/'> April 2008 &nbsp;(5)</option>
	<option value='https://haathitime.com/2008/03/'> March 2008 &nbsp;(6)</option>
	<option value='https://haathitime.com/2008/02/'> February 2008 &nbsp;(1)</option>
	<option value='https://haathitime.com/2008/01/'> January 2008 &nbsp;(1)</option>
	<option value='https://haathitime.com/2007/12/'> December 2007 &nbsp;(4)</option>
	<option value='https://haathitime.com/2007/11/'> November 2007 &nbsp;(7)</option>
	<option value='https://haathitime.com/2007/10/'> October 2007 &nbsp;(12)</option>
	<option value='https://haathitime.com/2007/09/'> September 2007 &nbsp;(15)</option>
	<option value='https://haathitime.com/2007/08/'> August 2007 &nbsp;(13)</option>
	<option value='https://haathitime.com/2007/07/'> July 2007 &nbsp;(30)</option>
	<option value='https://haathitime.com/2007/06/'> June 2007 &nbsp;(23)</option>
	<option value='https://haathitime.com/2007/05/'> May 2007 &nbsp;(10)</option>
	<option value='https://haathitime.com/2007/04/'> April 2007 &nbsp;(17)</option>
	<option value='https://haathitime.com/2007/03/'> March 2007 &nbsp;(14)</option>
	<option value='https://haathitime.com/2007/02/'> February 2007 &nbsp;(9)</option>
	<option value='https://haathitime.com/2007/01/'> January 2007 &nbsp;(14)</option>
	<option value='https://haathitime.com/2006/12/'> December 2006 &nbsp;(16)</option>
	<option value='https://haathitime.com/2006/11/'> November 2006 &nbsp;(7)</option>
	<option value='https://haathitime.com/2006/10/'> October 2006 &nbsp;(10)</option>
	<option value='https://haathitime.com/2006/09/'> September 2006 &nbsp;(9)</option>
	<option value='https://haathitime.com/2006/08/'> August 2006 &nbsp;(12)</option>
	<option value='https://haathitime.com/2006/07/'> July 2006 &nbsp;(14)</option>
	<option value='https://haathitime.com/2006/06/'> June 2006 &nbsp;(31)</option>
	<option value='https://haathitime.com/2006/05/'> May 2006 &nbsp;(18)</option>

		</select>
		</aside><aside id="wp_tag_cloud-2" class="widget wp_widget_tag_cloud"><h1 class="widget-title">Most used tags</h1><div style="overflow:hidden"><a href="https://haathitime.com/tag/55fiction/" class="tag-cloud-link tag-link-1816669 tag-link-position-1" style="font-size: 13.80487804878pt;" aria-label="55fiction (20 items)">55fiction</a>
<a href="https://haathitime.com/tag/apostaday-the-month-that-was/" class="tag-cloud-link tag-link-480022639 tag-link-position-2" style="font-size: 14.032520325203pt;" aria-label="APostADay: The month that was (22 items)">APostADay: The month that was</a>
<a href="https://haathitime.com/tag/being-a-wife/" class="tag-cloud-link tag-link-116385 tag-link-position-3" style="font-size: 17.276422764228pt;" aria-label="Being a wife (84 items)">Being a wife</a>
<a href="https://haathitime.com/tag/bheja-fry/" class="tag-cloud-link tag-link-1005412 tag-link-position-4" style="font-size: 17.674796747967pt;" aria-label="Bheja fry (98 items)">Bheja fry</a>
<a href="https://haathitime.com/tag/books/" class="tag-cloud-link tag-link-178 tag-link-position-5" style="font-size: 16.650406504065pt;" aria-label="Books (65 items)">Books</a>
<a href="https://haathitime.com/tag/brain-noodles/" class="tag-cloud-link tag-link-25177639 tag-link-position-6" style="font-size: 20.235772357724pt;" aria-label="Brain noodles (283 items)">Brain noodles</a>
<a href="https://haathitime.com/tag/change/" class="tag-cloud-link tag-link-14526 tag-link-position-7" style="font-size: 19.666666666667pt;" aria-label="Change (222 items)">Change</a>
<a href="https://haathitime.com/tag/fitness-and-health/" class="tag-cloud-link tag-link-30879 tag-link-position-8" style="font-size: 16.479674796748pt;" aria-label="Fitness and health (61 items)">Fitness and health</a>
<a href="https://haathitime.com/tag/food/" class="tag-cloud-link tag-link-586 tag-link-position-9" style="font-size: 18.30081300813pt;" aria-label="Food (129 items)">Food</a>
<a href="https://haathitime.com/tag/friendship-and-belonging/" class="tag-cloud-link tag-link-586775790 tag-link-position-10" style="font-size: 18.926829268293pt;" aria-label="Friendship and belonging (164 items)">Friendship and belonging</a>
<a href="https://haathitime.com/tag/gratitude/" class="tag-cloud-link tag-link-5411 tag-link-position-11" style="font-size: 15.626016260163pt;" aria-label="Gratitude (43 items)">Gratitude</a>
<a href="https://haathitime.com/tag/haiku/" class="tag-cloud-link tag-link-5790 tag-link-position-12" style="font-size: 16.024390243902pt;" aria-label="Haiku (50 items)">Haiku</a>
<a href="https://haathitime.com/tag/hits-the-spot/" class="tag-cloud-link tag-link-24789024 tag-link-position-13" style="font-size: 19.951219512195pt;" aria-label="Hits the spot (251 items)">Hits the spot</a>
<a href="https://haathitime.com/tag/home/" class="tag-cloud-link tag-link-400 tag-link-position-14" style="font-size: 18.983739837398pt;" aria-label="Home (170 items)">Home</a>
<a href="https://haathitime.com/tag/hungry-excited/" class="tag-cloud-link tag-link-164094596 tag-link-position-15" style="font-size: 16.593495934959pt;" aria-label="Hungry &amp; Excited (63 items)">Hungry &amp; Excited</a>
<a href="https://haathitime.com/tag/la-vita-e-bella/" class="tag-cloud-link tag-link-298127 tag-link-position-16" style="font-size: 20.577235772358pt;" aria-label="La vita e bella (320 items)">La vita e bella</a>
<a href="https://haathitime.com/tag/lessons/" class="tag-cloud-link tag-link-21227 tag-link-position-17" style="font-size: 18.30081300813pt;" aria-label="Lessons (128 items)">Lessons</a>
<a href="https://haathitime.com/tag/life-in-bangalore/" class="tag-cloud-link tag-link-161101 tag-link-position-18" style="font-size: 18.585365853659pt;" aria-label="Life in Bangalore (143 items)">Life in Bangalore</a>
<a href="https://haathitime.com/tag/life-in-goa/" class="tag-cloud-link tag-link-12186567 tag-link-position-19" style="font-size: 21.487804878049pt;" aria-label="Life in Goa (464 items)">Life in Goa</a>
<a href="https://haathitime.com/tag/looking-back/" class="tag-cloud-link tag-link-16187 tag-link-position-20" style="font-size: 17.959349593496pt;" aria-label="Looking back (111 items)">Looking back</a>
<a href="https://haathitime.com/tag/love-and-longing/" class="tag-cloud-link tag-link-13484767 tag-link-position-21" style="font-size: 18.926829268293pt;" aria-label="Love and longing (165 items)">Love and longing</a>
<a href="https://haathitime.com/tag/music/" class="tag-cloud-link tag-link-18 tag-link-position-22" style="font-size: 18.869918699187pt;" aria-label="Music (162 items)">Music</a>
<a href="https://haathitime.com/tag/my-family-and-other-animals/" class="tag-cloud-link tag-link-295285 tag-link-position-23" style="font-size: 17.674796747967pt;" aria-label="My family and other animals (100 items)">My family and other animals</a>
<a href="https://haathitime.com/tag/photographs/" class="tag-cloud-link tag-link-1151 tag-link-position-24" style="font-size: 22pt;" aria-label="Photographs (571 items)">Photographs</a>
<a href="https://haathitime.com/tag/sometimes-i-draw/" class="tag-cloud-link tag-link-26899474 tag-link-position-25" style="font-size: 12.837398373984pt;" aria-label="Sometimes I draw (13 items)">Sometimes I draw</a>
<a href="https://haathitime.com/tag/the-apprentice-diaries/" class="tag-cloud-link tag-link-117497918 tag-link-position-26" style="font-size: 11.69918699187pt;" aria-label="The Apprentice Diaries (8 items)">The Apprentice Diaries</a>
<a href="https://haathitime.com/tag/the-husband/" class="tag-cloud-link tag-link-91254 tag-link-position-27" style="font-size: 19.211382113821pt;" aria-label="The Husband (187 items)">The Husband</a>
<a href="https://haathitime.com/tag/the-rain/" class="tag-cloud-link tag-link-92508 tag-link-position-28" style="font-size: 17.276422764228pt;" aria-label="The rain (84 items)">The rain</a>
<a href="https://haathitime.com/tag/therapy-and-healing/" class="tag-cloud-link tag-link-41619600 tag-link-position-29" style="font-size: 17.50406504065pt;" aria-label="Therapy and healing (92 items)">Therapy and healing</a>
<a href="https://haathitime.com/tag/things-about-rere-that-i-want-to-forget/" class="tag-cloud-link tag-link-165268692 tag-link-position-30" style="font-size: 8pt;" aria-label="Things about Rere that I want to forget (1 item)">Things about Rere that I want to forget</a>
<a href="https://haathitime.com/tag/things-about-vc-that-i-never-want-to-forget/" class="tag-cloud-link tag-link-95225445 tag-link-position-31" style="font-size: 13.577235772358pt;" aria-label="Things about VC that I never want to forget (18 items)">Things about VC that I never want to forget</a>
<a href="https://haathitime.com/tag/travel/" class="tag-cloud-link tag-link-200 tag-link-position-32" style="font-size: 19.09756097561pt;" aria-label="Travel (178 items)">Travel</a>
<a href="https://haathitime.com/tag/vc-writes-too/" class="tag-cloud-link tag-link-165644096 tag-link-position-33" style="font-size: 9.0243902439024pt;" aria-label="VC writes too (2 items)">VC writes too</a>
<a href="https://haathitime.com/tag/what-coming-home-feels-like/" class="tag-cloud-link tag-link-581658763 tag-link-position-34" style="font-size: 12.837398373984pt;" aria-label="What coming home feels like (13 items)">What coming home feels like</a>
<a href="https://haathitime.com/tag/work/" class="tag-cloud-link tag-link-131 tag-link-position-35" style="font-size: 19.09756097561pt;" aria-label="Work (178 items)">Work</a>
<a href="https://haathitime.com/tag/writing/" class="tag-cloud-link tag-link-349 tag-link-position-36" style="font-size: 19.666666666667pt;" aria-label="Writing (221 items)">Writing</a></div></aside><aside id="text-6" class="widget widget_text">			<div class="textwidget"><a href="http://www.indiblogger.in/iba/entry.php?edition=1&amp;entry=43379" title="This blog won the 2013 Indian Blogger Awards - Personal">
<img src="https://i2.wp.com/www.indiblogger.in/iba/img/edition-1/winners-badges/4091.png" width="210" height="330" border="0" alt="This blog won the 2013 Indian Blogger Awards - Personal" />
</a>
</div>
		</aside><aside id="blog-stats-2" class="widget widget_blog-stats"><h1 class="widget-title">Stats</h1>		<ul>
			<li>457,751 people checked in</li>
		</ul>
		</aside>		<div class="wpcnt">
			<div class="wpa wpmrec">
				<span class="wpa-about">Advertisements</span>
				<div class="u">
							<div style="padding-bottom:15px;width:300px;height:250px;">
		<div id="atatags-235780263-5bc4be97610bf">
			<script type="text/javascript">
			__ATA.cmd.push(function() {
				__ATA.initSlot('atatags-235780263-5bc4be97610bf',  {
					collapseEmpty: 'before',
					sectionId: '235780263',
					width: 300,
					height: 250
				});
			});
			</script>
		</div></div>
				</div>
				
			</div>
		</div></div><!-- #secondary -->

	</div><!-- #content -->
		<footer id="colophon" class="site-footer" role="contentinfo">
		<div class="site-info">
			<a href="https://wordpress.com/?ref=footer_custom_powered">Powered by WordPress.com</a>.
			
					</div><!-- .site-info -->
	</footer><!-- #colophon -->
</div><!-- #page -->

<!--  -->
<script type='text/javascript' src='//0.gravatar.com/js/gprofiles.js?ver=201842y'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/wp-content/mu-plugins/gravatar-hovercards/wpgroho.js?m=1380573781h'></script>

	<script>
		//initialize and attach hovercards to all gravatars
		jQuery( document ).ready( function( $ ) {

			if (typeof Gravatar === "undefined"){
				return;
			}

			if ( typeof Gravatar.init !== "function" ) {
				return;
			}			

			Gravatar.profile_cb = function( hash, id ) {
				WPGroHo.syncProfileData( hash, id );
			};
			Gravatar.my_hash = WPGroHo.my_hash;
			Gravatar.init( 'body', '#wp-admin-bar-my-account' );
		});
	</script>

		<div style="display:none">
	</div>
<script type='text/javascript'>
/* <![CDATA[ */
var HighlanderComments = {"loggingInText":"Logging In\u2026","submittingText":"Posting Comment\u2026","postCommentText":"Post Comment","connectingToText":"Connecting to %s","commentingAsText":"%1$s: You are commenting using your %2$s account.","logoutText":"Log Out","loginText":"Log In","connectURL":"https:\/\/haathitime.wordpress.com\/public.api\/connect\/?action=request","logoutURL":"https:\/\/haathitime.wordpress.com\/wp-login.php?action=logout&_wpnonce=d312cc3ced","homeURL":"https:\/\/haathitime.com\/","postID":"11078","gravDefault":"identicon","enterACommentError":"Please enter a comment","enterEmailError":"Please enter your email address here","invalidEmailError":"Invalid email address","enterAuthorError":"Please enter your name here","gravatarFromEmail":"This picture will show whenever you leave a comment. Click to customize it.","logInToExternalAccount":"Log in to use details from one of these accounts.","change":"Change","changeAccount":"Change Account","comment_registration":"","userIsLoggedIn":"","isJetpack":"","text_direction":"ltr"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??/wp-content/js/jquery/jquery.autoresize.js,/wp-content/mu-plugins/highlander-comments/script.js?m=1521806916j'></script>

	<div id="carousel-reblog-box">
		<form action="#" name="carousel-reblog">
			<textarea id="carousel-reblog-content" name="carousel-reblog-content" placeholder="Add your thoughts here... (optional)"></textarea>
			<label for="carousel-reblog-to-blog-id" id="carousel-reblog-lblogid">Post to</label>
			<select name="carousel-reblog-to-blog-id" id="carousel-reblog-to-blog-id">
						</select>

			<div class="submit">
				<span class="canceltext"><a href="#" class="cancel">Cancel</a></span>
				<input type="submit" name="carousel-reblog-submit" class="button" id="carousel-reblog-submit" value="Reblog Post" />
				<input type="hidden" id="carousel-reblog-blog-id" value="23578026" />
				<input type="hidden" id="carousel-reblog-blog-url" value="https://haathitime.com" />
				<input type="hidden" id="carousel-reblog-blog-title" value="" />
				<input type="hidden" id="carousel-reblog-post-url" value="" />
				<input type="hidden" id="carousel-reblog-post-title" value="" />
			</div>

			<input type="hidden" id="_wpnonce" name="_wpnonce" value="4462fd99e0" /><input type="hidden" name="_wp_http_referer" value="/2018/10/15/day-288-all-along-this-love-was-right-in-front-of-me/" />		</form>

		<div class="arrow"></div>
	</div>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/haathitime.com\/2018\/10\/15\/day-288-all-along-this-love-was-right-in-front-of-me\/":11078};
	</script>
					<div id="sharing_email" style="display: none;">
		<form action="/2018/10/15/day-288-all-along-this-love-was-right-in-front-of-me/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
			
			<div
				class="g-recaptcha"
				data-sitekey="6LcmyE0UAAAAALID28yVNg7pFCodGaArJzHitez_"
				data-theme="light"
				data-type="image"
				data-tabindex="0"></div>
			<script type="text/javascript" src="https://www.google.com/recaptcha/api.js?hl=en" async></script>
			
			<img style="float: right; display: none" class="loading" src="https://s2.wp.com/wp-content/mu-plugins/post-flair/sharing/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
		<link rel='stylesheet' id='all-css-0-3' href='https://s0.wp.com/wp-content/mu-plugins/carousel/jetpack-carousel.css?m=1524699534h&cssminify=yes' type='text/css' media='all' />
<!--[if lte IE 8]>
<link rel='stylesheet' id='jetpack-carousel-ie8fix-css'  href='https://s1.wp.com/wp-content/mu-plugins/carousel/jetpack-carousel-ie8fix.css?m=1412618825h&#038;ver=20121024' type='text/css' media='all' />
<![endif]-->
<script type='text/javascript'>
/* <![CDATA[ */
var comment_like_text = {"loading":"Loading..."};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var actionbardata = {"siteID":"23578026","siteName":"haathitime.com","siteURL":"https:\/\/haathitime.com","icon":"<img alt='' src='https:\/\/s2.wp.com\/i\/logo\/wpcom-gray-white.png' class='avatar avatar-50' height='50' width='50' \/>","canManageOptions":"","canCustomizeSite":"","isFollowing":"","themeSlug":"pub\/lovecraft","signupURL":"https:\/\/wordpress.com\/start\/","loginURL":"https:\/\/haathitime.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Fhaathitime.com%2F2018%2F10%2F15%2Fday-288-all-along-this-love-was-right-in-front-of-me%2F","themeURL":"https:\/\/wordpress.com\/theme\/lovecraft\/","xhrURL":"https:\/\/haathitime.com\/wp-admin\/admin-ajax.php","nonce":"63c63525b2","isSingular":"1","isFolded":"","isLoggedIn":"","isMobile":"","subscribeNonce":"<input type=\"hidden\" id=\"_wpnonce\" name=\"_wpnonce\" value=\"46afe7539f\" \/>","referer":"https:\/\/haathitime.com\/2018\/10\/15\/day-288-all-along-this-love-was-right-in-front-of-me\/","canFollow":"1","feedID":"79491","statusMessage":"","customizeLink":"https:\/\/haathitime.wordpress.com\/wp-admin\/customize.php?url=https%3A%2F%2Fhaathitime.wordpress.com%2F2018%2F10%2F15%2Fday-288-all-along-this-love-was-right-in-front-of-me%2F","postID":"11078","shortlink":"https:\/\/wp.me\/p1AVIK-2SG","canEditPost":"","editLink":"https:\/\/wordpress.com\/post\/haathitime.com\/11078","statsLink":"https:\/\/wordpress.com\/stats\/post\/11078\/haathitime.com","i18n":{"view":"View site","follow":"Follow","following":"Following","edit":"Edit","login":"Log in","signup":"Sign up","customize":"Customize","report":"Report this content","themeInfo":"Get theme: Lovecraft","shortlink":"Copy shortlink","copied":"Copied","followedText":"New posts from this site will now appear in your <a href=\"https:\/\/wordpress.com\/\">Reader<\/a>","foldBar":"Collapse this bar","unfoldBar":"Expand this bar","editSubs":"Manage subscriptions","viewReader":"View site in Reader","viewReadPost":"View post in Reader","subscribe":"Sign me up","enterEmail":"Enter your email address","followers":"Join 1,333 other followers","alreadyUser":"Already have a WordPress.com account? <a href=\"https:\/\/haathitime.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Fhaathitime.com%2F2018%2F10%2F15%2Fday-288-all-along-this-love-was-right-in-front-of-me%2F\">Log in now.<\/a>","stats":"Stats"}};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/haathitime.com\/wp-admin\/admin-ajax.php","nonce":"e2714192c3","display_exif":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/haathitime.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Fhaathitime.com%2F2018%2F10%2F15%2Fday-288-all-along-this-love-was-right-in-front-of-me%2F","blog_id":"23578026","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>","reblog":"Reblog","reblogged":"Reblogged","reblog_add_thoughts":"Add your thoughts here... (optional)","reblogging":"Reblogging...","post_reblog":"Post Reblog","stats_query_args":"blog=23578026&v=wpcom&tz=5&user_id=0&subd=haathitime","is_public":"1","reblog_enabled":""};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s0.wp.com/_static/??-eJyVUu1OwzAMfCFSwyY07QfiUZCbup3bfBEnK3t7UmCj+1C1/Yp1vovPJ8MYlPYukUvQCzS0Z03hq+rlCWYtm1UwuWMnYHgggc9MmXboGkNxgay9tQVSv6J+UtcgIwd6RHQGXArTjmyhhVyD8XvSEdufVRzuucPE3t2r6Iyv0dzLloFDceQG1XqdRbV8So2dNrk59x4pmENl+crNbPGRm46SAOXS9QOTMjhCIhsMJrrAF/7BpsxRNUawKIliqVSxHiNPpk7Ygz+kiHq4in8u0lPak+hU3UpEwn8Ic7wvNxUPf081Z926EYw+CxnoKYXiSx2BJX8Di6Wk1tUzfJTJ0PpoF/jBS1KtQY4gO4zsuuNbRO/27eV1vdpuVuvtpv8GFiM6Mw=='></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-linkedin', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-pocket', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcompocket', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
</script>
<script type="text/javascript">
// <![CDATA[
(function() {
try{
  if ( window.external &&'msIsSiteMode' in window.external) {
    if (window.external.msIsSiteMode()) {
      var jl = document.createElement('script');
      jl.type='text/javascript';
      jl.async=true;
      jl.src='/wp-content/plugins/ie-sitemode/custom-jumplist.php';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(jl, s);
    }
  }
}catch(e){}
})();
// ]]>
</script>	<script type="text/javascript">
	var skimlinks_pub_id = "725X584219"
	var skimlinks_sitename = "haathitime.wordpress.com";
	</script>
	<script type="text/javascript" defer src="https://s.skimresources.com/js/725X1342.skimlinks.js"></script>		<iframe src='https://widgets.wp.com/likes/master.html?ver=20180319#ver=20180319' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
		<div id='likes-other-gravatars'><div class="likes-text"><span>%d</span> bloggers like this:</div><ul class="wpl-avatars sd-like-gravatars"></ul></div>
<script src="//stats.wp.com/w.js?56" type="text/javascript" async defer></script>
<script type="text/javascript">
_tkq = window._tkq || [];
_stq = window._stq || [];
_tkq.push(['storeContext', {'blog_id':'23578026','blog_tz':'5','user_lang':'en','blog_lang':'en','user_id':'0'}]);
_stq.push(['view', {'blog':'23578026','v':'wpcom','tz':'5','user_id':'0','post':'11078','subd':'haathitime'}]);
_stq.push(['extra', {'crypt':'UE5tW3cvZGRkOERlal9Yd291RzZXcmdOZVVpJVVkJTNPRktUU0lrQW9PVUpPZzRnc2JscmRuQmlTVEwtdEdNXUM1JkJGP2wmJkdUOWJZb3VsdFp1djYzdy1OflordnU0aiVLTVZ6bVsyJkE3ZU5hMlYmY2VVS08lMHV1a212QyxJRm9+LHI/SyVHcmZ0WnlmeXxYMGU5djhmQn4xfjZ+ODBmejUySj9BOSxxLmd3Yksyck1ZfHA1SHl8VV1HR2xsSjBvR1lraXJWfmtCb3A1aVBCWH43eXZ8c2JYRkxEb1dYMm53eS4vTUguVEE9OWRQM1lJWVIlTGFLPXY='}]);
_stq.push([ 'clickTrackerInit', '23578026', '11078' ]);
	</script>
<noscript><img src="https://pixel.wp.com/b.gif?v=noscript" style="height:0px;width:0px;overflow:hidden" alt="" /></noscript>
<script>
if ( 'object' === typeof wpcom_mobile_user_agent_info ) {

	wpcom_mobile_user_agent_info.init();
	var mobileStatsQueryString = "";
	
	if( false !== wpcom_mobile_user_agent_info.matchedPlatformName )
		mobileStatsQueryString += "&x_" + 'mobile_platforms' + '=' + wpcom_mobile_user_agent_info.matchedPlatformName;
	
	if( false !== wpcom_mobile_user_agent_info.matchedUserAgentName )
		mobileStatsQueryString += "&x_" + 'mobile_devices' + '=' + wpcom_mobile_user_agent_info.matchedUserAgentName;
	
	if( wpcom_mobile_user_agent_info.isIPad() )
		mobileStatsQueryString += "&x_" + 'ipad_views' + '=' + 'views';

	if( "" != mobileStatsQueryString ) {
		new Image().src = document.location.protocol + '//pixel.wp.com/g.gif?v=wpcom-no-pv' + mobileStatsQueryString + '&baba=' + Math.random();
	}
	
}
</script>
</body>
</html>
